Question

Loosing Connection on Linksys Velop Tri-Band Mesh Router

I have a query regarding my Linksys Velop Tri-Band Mesh Router that I am getting poor wifi signals for a couple of days.I am loosing connection.i have followed out the steps as guided by the support team to resolve this isue of Router Reviews Suggest us if we have anything to add on regarding the

  • Patricia Morr

  • 1

    Ans

  • 1 year ago

Answer Link
Answer - 1

It is a pretty annoying situation when your links will not try by mesh router and keeps on losing the connection. The problem is not so big and you can troubleshoot the issue on your own. Some of the things you can do on your own to avoid this problem are ensure a stable internet connection, update firmware regularly, try power cycling your router, check the placement of the router, make sure there is no interference, and try to reset and configure the router settings.

If after doing everything the problem is still not solved then you can consider taking professional help from Linksys support for guidance and assistance.

Losing Connection on Linksys Velop Tri-Band Mesh Router?

Try Checking the Internet Connection

If your Linksys Velop tri-band mesh router is losing connection then here is how it can detect the internet connection in the following simple steps-

Click on the option " I want to enter my ISP settings manually".

Now from here, you will have multiple options to choose from like -

  • Contact my ISP- You can click on this option if you want any guidance from the internet service provider.
  • Static IP address - In this, you have to form a connection with the default velop SSID and add your static IP address.
  • PPPoE Account - You have to connect to the default Velop wifi and add the PPPoE information.
  • VLAN ID with PPPoE- You have to connect to the default velop wifi and add the PPPoE information and VLAN ID.

You can also try detecting the connection one more time.

You can also continue without the internet and carry on with the setup wizard and configure the internet settings manually.

Try Checking the Admin Password Problem

While setting up the router the administrative password is set up automatically to protect the node. 

If you want to change it then -

  • Login to the envelope with the help of a Linksys cloud account.
  • Further, open the envelope administration.
  • Click on the "change envelope password and hint" option.
  • Create a new strong password and save the changes.

Try Restoring the Factory Fefault Settings

Sometimes factory reset is the only last option available. It can also solve many of the problems related to your router. So try to restore your router to the factory default settings. So, disconnect all the cables and reconnect them. With the help of this, all the customized settings will be deleted.

You can also reset the Linksys Velop tri-band mesh router by long pressing the Reset button until it stops flashing the red light then starts flashing the red light again.

  • Published by:  Mark   
  •  2 months ago